re = /\[%User\.(?<usernr>\d+?)%]/m
str = 'Hallo ich bin der [%User.123456789%], und ich bin ebenfalls ein User mit dem Namen [%User.987654321%]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end