const regex = new RegExp('\\[%User\\.(?<usernr>\\d+?)%]', 'gm')
const str = `Hallo ich bin der [%User.123456789%], und ich bin ebenfalls ein User mit dem Namen [%User.987654321%]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}