#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w\d._\-#])+@([\w\d._\-#]+[.][\w\d._\-#]+)+$"
Local $sString = "msekhar@yahoo.com" & @CRLF & _
"msekhar@cs.aau.edu" & @CRLF & _
"ms.sekhar@yahoo.com" & @CRLF & _
"ms_sekhar@yahoo.com" & @CRLF & _
"msekhar@cs2.aau.edu" & @CRLF & _
"msekhar@autobots.ai" & @CRLF & _
"msekhar@interior.homeland1.myanmar.mm" & @CRLF & _
"msekhar1922@yahoo.com" & @CRLF & _
"msekhar#21@autobots.com" & @CRLF & _
"\u001\u002@autobots.com" & @CRLF & _
"test tes @abcv.coa" & @CRLF & _
"test.com@.com" & @CRLF & _
"aas" & @CRLF & _
"@test.xy" & @CRLF & _
"test.com@abc" & @CRLF & _
"" & @CRLF & _
"test-xy@gmail.c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")