const regex = /^([\w\d._\-#])+@([\w\d._\-#]+[.][\w\d._\-#]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\\d._\\-#])+@([\\w\\d._\\-#]+[.][\\w\\d._\\-#]+)+$', 'gm')
const str = `msekhar@yahoo.com
msekhar@cs.aau.edu
ms.sekhar@yahoo.com
ms_sekhar@yahoo.com
msekhar@cs2.aau.edu
msekhar@autobots.ai
msekhar@interior.homeland1.myanmar.mm
msekhar1922@yahoo.com
msekhar#21@autobots.com
\\u001\\u002@autobots.com
test tes @abcv.coa
test.com@.com
aas
@test.xy
test.com@abc
test-xy@gmail.c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}