$re = '/^([\w\d._\-#])+@([\w\d._\-#]+[.][\w\d._\-#]+)+$/m';
$str = 'msekhar@yahoo.com
msekhar@cs.aau.edu
ms.sekhar@yahoo.com
ms_sekhar@yahoo.com
msekhar@cs2.aau.edu
msekhar@autobots.ai
msekhar@interior.homeland1.myanmar.mm
msekhar1922@yahoo.com
msekhar#21@autobots.com
\\u001\\u002@autobots.com
test tes @abcv.coa
test.com@.com
aas
@test.xy
test.com@abc
test-xy@gmail.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);