using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w\d._\-#])+@([\w\d._\-#]+[.][\w\d._\-#]+)+$";
string input = @"msekhar@yahoo.com
msekhar@cs.aau.edu
ms.sekhar@yahoo.com
ms_sekhar@yahoo.com
msekhar@cs2.aau.edu
msekhar@autobots.ai
msekhar@interior.homeland1.myanmar.mm
msekhar1922@yahoo.com
msekhar#21@autobots.com
\u001\u002@autobots.com
test tes @abcv.coa
test.com@.com
aas
@test.xy
test.com@abc
test-xy@gmail.c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}