import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:export\\s+|)(?<key>[[:alnum:]_]+)=((?<quote>[\"'])?(?<val>.*?[^\\\\])\\k<quote>?|)$";
final String string = "DOT_ENV=dotenv\n"
+ "#DOTENV=dotenv\n"
+ "DOT_ENV= asdf asf \n"
+ "DOTENV='dot env'\n"
+ "DOTENV=\"dot env\"\n"
+ "DOT_ENV='dotenv'\n"
+ "DOT_ENV=\"DotEnv\"\n"
+ "DOTENV=\"Dot\\nEnv\"\n"
+ "DOTENV=\"{\"Dot\":\"Env\"}\"\n"
+ "export DOTENV=\"dotenv\"\n"
+ "DOTENV =\"dot env\"\n"
+ "DOTENV= \"dot env\"\n"
+ "DOTENV = \"dot env\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}