re = /^(?:export\s+|)(?<key>[[:alnum:]_]+)=((?<quote>["'])?(?<val>.*?[^\\])\k<quote>?|)$/m
str = 'DOT_ENV=dotenv
#DOTENV=dotenv
DOT_ENV= asdf asf
DOTENV=\'dot env\'
DOTENV="dot env"
DOT_ENV=\'dotenv\'
DOT_ENV="DotEnv"
DOTENV="Dot\\nEnv"
DOTENV="{"Dot":"Env"}"
export DOTENV="dotenv"
DOTENV ="dot env"
DOTENV= "dot env"
DOTENV = "dot env"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end