import re
regex = re.compile(r"^(?:export\s+|)(?<key>[[:alnum:]_]+)=((?<quote>[\"'])?(?<val>.*?[^\\])\k<quote>?|)$", flags=re.MULTILINE)
test_str = ("DOT_ENV=dotenv\n"
"#DOTENV=dotenv\n"
"DOT_ENV= asdf asf \n"
"DOTENV='dot env'\n"
"DOTENV=\"dot env\"\n"
"DOT_ENV='dotenv'\n"
"DOT_ENV=\"DotEnv\"\n"
"DOTENV=\"Dot\\nEnv\"\n"
"DOTENV=\"{\"Dot\":\"Env\"}\"\n"
"export DOTENV=\"dotenv\"\n"
"DOTENV =\"dot env\"\n"
"DOTENV= \"dot env\"\n"
"DOTENV = \"dot env\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")