re = /(\.\[[^][]*\])\s*/m
str = 'It reported the proportion of the edits made from America was 51% for the Wikipedia, and 25% for the simple Wikipedia.[142] The Wikimedia Foundation hopes to increase the number in the Global South to 37% by 2015.[143]'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result