#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n{2,}"
Local $sString = "00" & @CRLF & _
"aa" & @CRLF & _
"" & @CRLF & _
"bb" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"cc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"dd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ee" & @CRLF & _
"ff" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)