import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n{2,}";
final String string = "00\n"
+ "aa\n\n"
+ "bb\n\n\n"
+ "cc\n\n\n\n"
+ "dd\n\n\n\n\n"
+ "ee\n"
+ "ff\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}