$re = '/\n{2,}/m';
$str = '00
aa
bb
cc
dd
ee
ff
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;