#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\s*\n)\1"
Local $sString = "" & @CRLF & _
" Another line of text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Another line of text" & @CRLF & _
"" & @CRLF & _
" Yet another line of text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Your boring line of text." & @CRLF & _
" " & @CRLF & _
" More of the same." & @CRLF & _
"" & @CRLF & _
" Will this never end?" & @CRLF & _
"" & @CRLF & _
" Keeps giving."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)