import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\s*\\n)\\1";
final String string = "\n"
+ " Another line of text\n\n\n"
+ " Another line of text\n\n"
+ " Yet another line of text\n\n\n"
+ " Your boring line of text.\n"
+ " \n"
+ " More of the same.\n\n"
+ " Will this never end?\n\n"
+ " Keeps giving.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}