import Foundation
let pattern = #"(^\s*\n)\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Another line of text
Another line of text
Yet another line of text
Your boring line of text.
More of the same.
Will this never end?
Keeps giving.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)