$re = '/(^\s*\n)\1/m';
$str = '
Another line of text
Another line of text
Yet another line of text
Your boring line of text.
More of the same.
Will this never end?
Keeps giving.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;