import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?:https|http):\\/\\/)|(?:\\/)).+(?:.mp3|mp4)";
final String string = "<a herf=\"https://regex101.com/index.mp3\">\n"
+ "<a herf=\"/index.mp3\">\n"
+ "https://regex101.com/index.mov\n"
+ "https://regex101.com/index.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}