re = /(?:((?:https|http):\/\/)|(?:\/)).+(?:.mp3|mp4)/m
str = '<a herf="https://regex101.com/index.mp3">
<a herf="/index.mp3">
https://regex101.com/index.mov
https://regex101.com/index.mp4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end