// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:((?:https|http):\/\/)|(?:\/)).+(?:.mp3|mp4)").unwrap();
let string = "<a herf=\"https://regex101.com/index.mp3\">
<a herf=\"/index.mp3\">
https://regex101.com/index.mov
https://regex101.com/index.mp4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}