const regex = /(?:((?:https|http):\/\/)|(?:\/)).+(?:.mp3|mp4)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?:https|http):\\\/\\\/)|(?:\\\/)).+(?:.mp3|mp4)', 'gm')
const str = `<a herf="https://regex101.com/index.mp3">
<a herf="/index.mp3">
https://regex101.com/index.mov
https://regex101.com/index.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}