use strict;
my $str = ' Имя Фамилия Отчество';
my $regex = qr/^\h*\S+\h+(\S+)[^\n]+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";