re = /^\h*\S+\h+(\S+)[^\n]+/m
str = ' Имя Фамилия Отчество'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result