#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0?[0-9]{0,4}(?:\.\d+)?|1\d{4}(?:\.\d+)?|20[0-4][0-7][0-8](?:\.\d+)?|20479(?:\.[0-7])?)$"
Local $sString = "12" & @CRLF & _
"20" & @CRLF & _
"50" & @CRLF & _
"50.45" & @CRLF & _
"9999" & @CRLF & _
"10000" & @CRLF & _
"10000.12" & @CRLF & _
"16000" & @CRLF & _
"19000" & @CRLF & _
"19999" & @CRLF & _
"20000.54" & @CRLF & _
"20479" & @CRLF & _
"20479.00" & @CRLF & _
"20479.1" & @CRLF & _
"20479.7" & @CRLF & _
"" & @CRLF & _
"Non matching:" & @CRLF & _
"20479.8" & @CRLF & _
"20480" & @CRLF & _
"21000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")