$re = '/^(0?[0-9]{0,4}(?:\.\d+)?|1\d{4}(?:\.\d+)?|20[0-4][0-7][0-8](?:\.\d+)?|20479(?:\.[0-7])?)$/m';
$str = '12
20
50
50.45
9999
10000
10000.12
16000
19000
19999
20000.54
20479
20479.00
20479.1
20479.7
Non matching:
20479.8
20480
21000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);