using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(((?:[^()]+|(?R))*+)\)";
string input = @"(Hello OR there) AND (big AND wide AND world)
(Hello OR there AND messing(it)up) AND (big AND wide AND world)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}