package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(((?:[^()]+|(?R))*+)\)`)
var str = `(Hello OR there) AND (big AND wide AND world)
(Hello OR there AND messing(it)up) AND (big AND wide AND world)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}