$re = '/\(((?:[^()]+|(?R))*+)\)/m';
$str = '(Hello OR there) AND (big AND wide AND world)
(Hello OR there AND messing(it)up) AND (big AND wide AND world)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);