re = /\(((?:[^()]+|(?R))*+)\)/m
str = '(Hello OR there) AND (big AND wide AND world)
(Hello OR there AND messing(it)up) AND (big AND wide AND world)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end