using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\+46|0046|0)7[02369]+[\d]{7})|((\+45|0045|0)(([2][0-9]|31|40|41|42|50|51|52|53|60|61|71|81|91)+[\d]{6}))|((\+47|0047|0)(([4]|[9])+[\d]{7}))|((\+358|00358|0)(([4][0-9])|457|50)+[\d]{7})";
string input = @"+3584571234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}