// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\+46|0046|0)7[02369]+[\d]{7})|((\+45|0045|0)(([2][0-9]|31|40|41|42|50|51|52|53|60|61|71|81|91)+[\d]{6}))|((\+47|0047|0)(([4]|[9])+[\d]{7}))|((\+358|00358|0)(([4][0-9])|457|50)+[\d]{7})").unwrap();
let string = "+3584571234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}