import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\+46|0046|0)7[02369]+[\\d]{7})|((\\+45|0045|0)(([2][0-9]|31|40|41|42|50|51|52|53|60|61|71|81|91)+[\\d]{6}))|((\\+47|0047|0)(([4]|[9])+[\\d]{7}))|((\\+358|00358|0)(([4][0-9])|457|50)+[\\d]{7})";
final String string = "+3584571234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}