const regex = /((\+46|0046|0)7[02369]+[\d]{7})|((\+45|0045|0)(([2][0-9]|31|40|41|42|50|51|52|53|60|61|71|81|91)+[\d]{6}))|((\+47|0047|0)(([4]|[9])+[\d]{7}))|((\+358|00358|0)(([4][0-9])|457|50)+[\d]{7})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\+46|0046|0)7[02369]+[\\d]{7})|((\\+45|0045|0)(([2][0-9]|31|40|41|42|50|51|52|53|60|61|71|81|91)+[\\d]{6}))|((\\+47|0047|0)(([4]|[9])+[\\d]{7}))|((\\+358|00358|0)(([4][0-9])|457|50)+[\\d]{7})', 'gm')
const str = `+3584571234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}