using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""":method""[:""a-z,/\d-]{20,1000}/copy";
string input = @""":method"":""POST"","":path"":""/api/browser/projects/8bd4d1d3-0b69-515e-8e15-e9c49992f7d5/buckets/b-ao-mock-testing/copy";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}