re = /":method"[:"a-z,\/\d-]{20,1000}\/copy/mi
str = '":method":"POST",":path":"/api/browser/projects/8bd4d1d3-0b69-515e-8e15-e9c49992f7d5/buckets/b-ao-mock-testing/copy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end