import re
regex = re.compile(r'":method"[:"a-z,/\d-]{20,1000}/copy', flags=re.MULTILINE | re.IGNORECASE)
test_str = "\":method\":\"POST\",\":path\":\"/api/browser/projects/8bd4d1d3-0b69-515e-8e15-e9c49992f7d5/buckets/b-ao-mock-testing/copy"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")