#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(s|f|dn)|(\d{2}d)|(\d+\.\d+))$"
Local $sString = "ss" & @CRLF & _
"dnf" & @CRLF & _
"305d" & @CRLF & _
"sf" & @CRLF & _
"20." & @CRLF & _
".45" & @CRLF & _
"" & @CRLF & _
"35d" & @CRLF & _
"s" & @CRLF & _
"f" & @CRLF & _
"dn" & @CRLF & _
"20.45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")