re = /^(?:(s|f|dn)|(\d{2}d)|(\d+\.\d+))$/m
str = 'ss
dnf
305d
sf
20.
.45
35d
s
f
dn
20.45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end