// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(s|f|dn)|(\d{2}d)|(\d+\.\d+))$").unwrap();
let string = "ss
dnf
305d
sf
20.
.45
35d
s
f
dn
20.45";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}