$re = '/^(?:(s|f|dn)|(\d{2}d)|(\d+\.\d+))$/m';
$str = 'ss
dnf
305d
sf
20.
.45
35d
s
f
dn
20.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);