using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?>[^)(]*(?1)?)*\))(*SKIP)(*F)|,";
string input = @"xyz(text1,(text2,text3)),asd
foo,bar(bar(lorem,ipse(dolor,sit)))baz,bar,baz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}