$re = '/(\((?>[^)(]*(?1)?)*\))(*SKIP)(*F)|,/';
$str = 'xyz(text1,(text2,text3)),asd
foo,bar(bar(lorem,ipse(dolor,sit)))baz,bar,baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);