import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?>[^)(]*(?1)?)*\\))(*SKIP)(*F)|,";
final String string = "xyz(text1,(text2,text3)),asd\n"
+ "foo,bar(bar(lorem,ipse(dolor,sit)))baz,bar,baz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}