re = /(\((?>[^)(]*(?1)?)*\))(*SKIP)(*F)|,/
str = 'xyz(text1,(text2,text3)),asd
foo,bar(bar(lorem,ipse(dolor,sit)))baz,bar,baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end