re = /^(.+)(.*)\1$/m
str = 'abXYab
xx
xxx
xxxx
javaXYZjava
javajava
Hello! and Hello!
x
abcd
mymmy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end