#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-[0-9]+-?$"
Local $sString = "gaf-3" & @CRLF & _
"gaf-3-9-101231241414" & @CRLF & _
"brian-11231241434" & @CRLF & _
"cmartins-4-23423424" & @CRLF & _
"gaf-5-63242342"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")