re = /-[0-9]+-?$/m
str = 'gaf-3
gaf-3-9-101231241414
brian-11231241434
cmartins-4-23423424
gaf-5-63242342'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end