using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-[0-9]+-?$";
string input = @"gaf-3
gaf-3-9-101231241414
brian-11231241434
cmartins-4-23423424
gaf-5-63242342";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}