// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-[0-9]+-?$").unwrap();
let string = "gaf-3
gaf-3-9-101231241414
brian-11231241434
cmartins-4-23423424
gaf-5-63242342";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}