using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^/\n]+/[^/\n]+$";
string input = @"20200507-30g_25d
20200507-30g_25d/ggg
20200507-30g_25d/grn
20200507-30g_25d/ylw
ggg
grn
tre_livelli
tre_livelli/20200507-30g_25d
tre_livelli/20200507-30g_25d/ggg
tre_livelli/20200507-30g_25d/grn
tre_livelli/20200507-30g_25d/ylw
ylw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}